Check Point выпустил защиту от критически опасной уязвимости Heartbleed

18 Апреля, 2014 14:42
Компания Check Point Software Technologies Ltd, сообщает о том, что ее продукты по сетевой безопасности обеспечивают всестороннюю защиту от уязвимости Heartbleed, включая безопасность клиентских систем, серверов и целостность передаваемых в сети данных.

Решения Check Point для сетевой безопасности не подвержены эксплойтам Heartbleed, так как компания использовала в них неуязвимую версию программной библиотеки OpenSSL. Также решения Check Point обеспечивают многоуровневую защиту от атак, использующих баг Heartbleed, которая включает:

  • Check Point выполняет расширенные проверки протокола HTTPS, что автоматически предотвращает трафик Heartbleed. Эти проверки появились в 2011 году в версии R75.20.
  • Специальные сигнатуры IPS для обнаружения и блокирования эксплойтов уязвимости Heartbleed были выпущены Check Point 9 апреля 2014 года.

«Уязвимость Heartbleed является критически опасной угрозой и может иметь далеко идущие последствия, потенциально открывая хакерам доступ к конфиденциальным и бизнес-данным. Продукты Check Point предоставляют различные элементы защиты от Heartbleed. Во-первых, наши решения для сетевой безопасности сами по себе не уязвимы для этой угрозы, так как Check Point использует некомпрометированную версию OpenSSL. Во-вторых, наши средства проверки протокола HTTPS в своей основе блокируют трафик Heartbleed. Наконец, своевременно выпущенная защита IPS будет обнаруживать и блокировать попытки использования этой уязвимости», — говорит Дорит Дор (Dorit Dor), вице-президент по продуктам, Check Point Software Technologies.

Дополнительная информация о Heartbleed:

  • В базе National Vulnerability Database (NVD) Common Vulnerabilities and Exposures уязвимость CVE-2014-0160, также известная. как «Heartbleed», описывается следующим образом: «Версии (1) TLS и (2) DTLS в протоколе OpenSSL 1.0.1 до версии 1.0.1g неправильно обрабатывают пакеты расширения Heartbeat Extension, что позволяет злоумышленникам удаленно завладевать ценной информацией из памяти процесса. Хакеры используют специально разработанные пакеты, приводящие к переполнению буфера чтения — о чем свидетельствует считывание частных ключей.…и этот процесс получил название бага Heartbleed».
  • Heartbleed.com описывает уязвимость следующим образом: «Ошибка Heartbleed — это серьезная уязвимость в популярной криптографической библиотеке OpenSSL. Она позволяет любому пользователю интернета считывать данные из памяти систем, использующих уязвимые версии OpenSSL. Таким образом, происходит компрометация секретных ключей, используемых провайдером для идентификации и шифрования трафика, имен пользователей, паролей и другого контента. Это позволяет злоумышленникам перехватывать коммуникации, красть данные самих сервисов и пользователей, а также подделывать ID (идентификационные данные пользователей)».

«Уязвимость Heartbleed вызывает серьезное беспокойство в связи с распространенностью использования OpenSSL и тем фактом, что потребители зачастую игнорируют необходимость применения сложных паролей, подвергая себя риску. Более того, компаниям необходимо беспокоиться не только о потере информации об учетных записей пользователей, но также о компрометации учетных данных сотрудников и о доступе к сетевым устройствам, использующим OpenSSL», — говорит Джон Грэди (John Grady), менеджер по исследованиям продуктов и услуг в сфере безопасности, IDC.

Комментарии:

НОВЫЕ СТАТЬИ

Новая стратегия NetApp: первые плоды
Владимир Смирнов Вчера 10:51
Сетевое оборудование Cisco по подписке
Владимир Смирнов 20 Ноября 10:09
Представлен «Самый быстрый Firefox»
Иван Николенко 16 Ноября 10:13